Patch #5 Released for V2.4.2

Friday, March 16, 2018 Tags: patch, release, bugs

This patch addresses another error introduced in Exponent CMS v2.4.1patch6 which prevented new users from creating a new account in non-eCommerce installations. It also many other minor issues. We strongly encourage all Exponent installations be upgraded to v2.4.2 with this patch as soon as practical! Patch #5 to v2.4.2 is found at https://sourceforge.net/projects/exponentcms/files/exponent-2.4.2-patch-5.zip/download 
 

v242patch5 adds these features to v242 and previous patches:

- adds small device responsive view to store show product w/ child products in bs3 framework

- uses speedier casting instead of intval/floatval/stringval functions

- update delete products/categories to better clean up associated tables

- adds new optional upgrade script to remove orphan eCommerce records

- adds customer stats to ecommerce dashboard, splits out dashboard data

- add delete confirmation to bootstrap store category tree deletions

- add autoplay setting to media player

 

v242patch5 fixes these issues in v242 and previous patches:

- regression fix (v242) unable to update existing form records

- regression fix (v241p6) new users unable to create new account (non-ecommerce)

- regression fix (v242p1) IIS support always switches to https urls

- regression fix orders report, show payment summary tax data not displayed

- regression fix (v242p4) images in manage products not displayed

- regression fix media player youtube videos fail to play when multiple videos are on a page

- fix unused tables shouldn't list forms data tables for removal

- fix product model complains when doing update() from other than edit view

- fix fix_sef_urls upgrade script to not add an sef_url to child products

- fix photoalbum configuration to not send duplicate config settings from both 'gallery' and 'module view' tabs

- fix some cross-domain loading issues for https: sites (fonts, maps)

- fix bootstrap 4 support in orders and printer-friendly views

 

v242patch5 updates these 3rd party libraries in v242 and previous patches:

- TinyMCE to v4.7.9

- Adminer db manager to v4.6.2

- moment.js to v2.21.0u

- owlCarousel2 to v2.3.2

- elFinder to v2.1.33